Lenkschleifer springt über Hall-Sensor

Für Diskussionen rund ums Car-System und bewegte H0-Autos
Antworten
herbi39

Lenkschleifer springt über Hall-Sensor

Beitrag von herbi39 » Samstag 31. Januar 2015, 19:40

Hallo zusammen,

nachdem ich meine Teststrecke mit Hall-Sensoren ausgestattet habe, stehe ich nun vor folgendem Problem.

Ich verwende den normalen Faller Fahrdraht!

Während meine älteren Car System Fahrzeuge ohne Beanstandung über die Sensoren fahren, ist das bei einem neuen Bus den ich heute bekommen habe nicht der Fall.
Soblad er einen Sensor überfährt sieht es aus als ob einer ins Lekrad greift, das heißt der Lenkschleifer zuckt kurz und der Bus verliert manchmal die Spur, manchmal nach links, manchmal nach rechts.

Gibt es eine Möglichkeit, daß das Magnetfeld am Sensor nicht unterbrochen wird, ohne diesen zu beeinflußen?

Ich habe ein kurzes Video gemacht auf dem ihr das Verhalten des von Hand über den Sensor geschobenen Lenkschleifers sehen könnt.
http://youtu.be/VYVxohTQMlM

Ich hoffe ihr habt eine Idee, wie man das in den Griff bekommen kann!

Viele Grüße
Herbert
http://www.herberts-n-projekt.de

Benutzeravatar
TorstenF
Forumane
Beiträge: 498
Registriert: Sonntag 16. Januar 2011, 14:56
Wohnort: bei mir zu Hause

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von TorstenF » Sonntag 1. Februar 2015, 09:34

Hallo Herbert,

der Lenkmagnet ist einfach nur auf der Suche nach etwas an dem er sich "festhalten" kann.
Deshalb auch diese Zucken was man in deinem Video sehen kann.
Erstmal würde ich versuchen die Unterbrechung des Fahrdrahtes zu klein wie möglich zu machen. Also Drahtende, sofort der Sensor und dann wieder der Draht. Keine Luft dazwischen!
Und dann kann man auf der weiterführenden Seite noch sogn. Fangdrähte mit einbauen die bei einem Ausbruch den Lenkmagneten wieder auf den eigentlichen Fahrdraht führen.
Grüße aus Hilden
Torsten

herbi39

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von herbi39 » Sonntag 1. Februar 2015, 10:30

Hallo Torsten,

das mit den Fangdrähten ist eine gute Idee, könnte von mir sein :D ich weiß auch nicht, warum ich da nicht selber drauf gekommen bin.

Das ist das nächste was ich jetzt noch probieren werde.

Vielen Dank und

Benutzeravatar
disetze
Stammgast
Beiträge: 149
Registriert: Montag 12. Juli 2010, 18:05
Wohnort: Breckerfeld

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von disetze » Sonntag 1. Februar 2015, 16:17

Hallo Herbert,

es müsste noch eine weiter Mörlichkeit geben deine Fahrzeuge gefahrlos über den Hallsensor zu bekommen. Den Draht einfach durchziehen und den Hallsensor unter dem Fahrdraht positionieren. Der Lenkmagnet ist auf jeden Fall stark genung um den Hallsensor zu schalten!

Gruß Dirk
Mit freundlichem Gruß vom Luftkurort Breckerfeld
Ich bin ein DC-Car`ler
https://www.youtube.com/user/disetze
http://www.mec-halver.de

herbi39

Gelöst: Lenkschleifer springt über Hall-Sensor

Beitrag von herbi39 » Sonntag 1. Februar 2015, 17:42

Hallo zusammen,

@Dirk,
das habe ich probiert und funktioniert mit dem Magneten eines Spur N Fahrzeugs leider nicht!

!!! Problem gelöst !!!

wenn es normalerweise auch sehr erfreulich ist, daß die Lenkachse extrem leichtgängig ist, wurde es mir zum Verhängnis.

Ich hatte die TLE längs eingebaut um zu verhindern, daß der Fahrdraht die Anschlußbeine berühren kann, dadurch ergab sich ein Abstand der beiden Fahrdrahtenden von mindestens 4,5-5,0mm. Dies hat jedoch zur Folge, daß ein neuer, noch starker Lenkmagnet versucht sich mit aller Kraft am nächsten Punkt festzuhalten. Dies war in meinem Fall der Draht von dem er gekommen war.
Durch den großen Abstand wurde der Lenkmagnet nach hinten gezogen bevor das Drahtende nach dem Sensor für ihn erreichbar war.
Da jedoch der Bus in Bewegung war, führte dies zu einem Lenkausschlag und ausbrechen des Fahrzeuges.

Ich habe nun testweise einen TLE quer zur Fahrtrichtung eingebaut und einen Abstand von 3,0-3,5mm zwischen den Drahtenden und dadurch das Problem gelöst, da das nächste Drahtende erreicht wird bevor das Fahrzeug ausbricht.

Diese Probleme treten bei nicht extrem leichtgänigen Lenkachsen, schwächern Magneten oder H0 Fahrzeugen vermutlich nicht auf!

Ich hoffe, daß ich das jetzt Alles einigermaßen verständlich geschrieben haben und bedanke mich nochmals für eure Unterstützung!

Benutzeravatar
Dankwardt
Forumane
Beiträge: 1750
Registriert: Montag 27. Oktober 2003, 23:12
Wohnort: 40721 Hilden - 402 km von Hamburg
Kontaktdaten:

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von Dankwardt » Montag 2. Februar 2015, 03:16

Was Herbert hier beschrieben hat trifft auch H0 PKW zu.

Statt den Lenkdraht über den Hallsensore zu führen, kann an Draht auch unter den Hallsensor führen.
Ohne Enden gibt es kein springendes Magnetfeld.

Jedes Metall hat einen magnetischen Pol.
Wenn es nicht durch das schmache Erdmagnetfeld entstrande ist,
wird ein Draht auch von einem stromführenden Kabel magnetisiert.
Es reicht auch ein Fahrzeug mit dem Lenkmagnet auf dem Draht stehen zu lassen und man bekommt einem Magneten in der Fahrbahn.
Die Enden sind immer einen Pol.Wenn man keine Enden hat gibt es auch keine Pol die den Lenkmagnet ablenken können.

Bei mir wurden durch den Stromfluss im Hallsensor die Fahrzeug aus der Spur gedrückt.
Deshalb bei der neuen Testanlage nur noch IR-Rückmelder.
Gruß Siegmund
So geht die Rettungsgasse!
Schon in der modellbau-wiki.de gesucht?
oder bei modellautobahnen.de
oder Steuerungen für Car-Systeme -> WIKI.DC-Car
oder Forum.DC-Car.de

LordBrummi
Stammgast
Beiträge: 163
Registriert: Freitag 3. Oktober 2003, 10:46

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von LordBrummi » Freitag 3. November 2017, 22:25

Hallo zusammen,

dieses ‚Problem, gehört demnächst der Vergangenheit an, da man das Magnetband nicht mehr unterbrechen muß und den Hallsensor einfach unter der Straße plaziert (und nicht mehr wie bisher auf der Straße auf selber Höhe wie das Magnetband).

Schaut selbst:

https://youtu.be/jCaVQDaETy4

Grüße Dieter
Es wird alles gut .......

MECler
Forumsgast
Beiträge: 37
Registriert: Donnerstag 2. April 2009, 10:11

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von MECler » Freitag 17. November 2017, 18:06

Hallo Dieter,

das Thema werde ich weiter beobachten. Wenn ich es richtig sehe, löst jedes Aufsetzen und Abheben des Lenkschleifers einen Impuls aus (LED leuchtet). Wenn das immer passiert, ist die Prellfreiheit des Hall-Sensors dahin. Ohne mich im anderen Forum anzumelden, wäre für mich die Funktion interessant, wenn mehrere Hall-Sensoren hintereinander unter dem gleichen Magnetband liegen.

Gruß Rico

LordBrummi
Stammgast
Beiträge: 163
Registriert: Freitag 3. Oktober 2003, 10:46

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von LordBrummi » Freitag 17. November 2017, 19:04

Hallo,

nein, das rhythmische Blinken zeigt nur an, daß der Sensor aktiv ist (mit Spannung versorgt, daß er lebt sozusagen).
Das ist ne Firmware Geschichte und kann auch abgeschalten werden, finde ich aber nützlich.

Es hat also nichts mit Auf- oder Absetzen des Lenkschleifers zu tun.

Grüße Dieter
Es wird alles gut .......

blaulicht
Forumsgast
Beiträge: 1
Registriert: Samstag 19. Januar 2019, 12:11

Re: Lenkschleifer springt über Hall-Sensor

Beitrag von blaulicht » Samstag 19. Januar 2019, 12:22

Hallo ein paar Fragen in die Runde

Bei Umbau arbeiten an meinem Modul hab ich gesehen das die Magnetbänder in der Straße porös geworden sind bei den Servo Weichen ist sogar das Band auf dem Servo Arm abgerissen da braucht man sich dann auch nicht wunden das das Auto nicht abbiegt!!

Was kann man dagegen machen?

Und wie macht ihr das mit Hallsensoren in der Fahrbahn führt ihr das Magnetband vor dem Hallsensor nach unten oder last ihr das bis zum Sensor bündig gehen?

Dieselbe Frage hab ich auch bei spitz zulaufenden Fahrbahnen stößt ihr mit den Bändern zusammen oder führt ihr an den Übergängen das band nach unten wie man es bei Magnetband Verlängerungen macht??


Mit freundlichen Grüßen.

Christian

Antworten